The Diesel Garage banner
1 - 19 of 19 Posts

·
Junior Member
Joined
·
28 Posts
Discussion Starter · #1 ·
I have a 2003 f350 diesel with automatic, my tow haul light on the shifter lever is flashing and the truck will not go into overdrive, and the Transmission Fluid Temperature gauge is pegged, But I let it sit for about a hour and it drove fine for 20 min and it did it again.what does this mean?
 

·
Registered
Joined
·
624 Posts
tranny is in limp mode. it could be because of the over heating or the over heating is being caused by something else(plugged cooler or inturnal failure of some part) but it aint good. need to quit driving it and get it to the shop.

Scott
 

·
Junior Member
Joined
·
28 Posts
Discussion Starter · #3 ·
Yes but the gauge will read about half way up or should I say in the middle and then bam it will peg and the check gauge light on the dash comes on and the tow haul light starts flashing, It is not getting hot!
 

·
Registered
Joined
·
239 Posts
that factory trans temp guage is a bunch of BS so I wouldnt say it isnt getting hot.
 

·
SLAPS President
Joined
·
3,027 Posts
Your symptoms seem to indicate the sensor is faulty and has thrown the truck in to "limp" mode because it believes the tranny is overheating..... Faulty trans temp senders is a well known and well documented problem.... I suspect that is your problem..... A change in factory temp sensors will likely cure the issue.....
 

·
Senior Member
Joined
·
1,660 Posts
agree its the sensor.
 

·
Junior Member
Joined
·
24 Posts
The same thing happened to me last year. It is a sensor inside the tranny. The trans isn't actually heating up that much though.
 

·
Junior Member
Joined
·
28 Posts
Discussion Starter · #9 ·
Teamroper60 Thank you!!!! Replaced the sensor and it is all good,But had to buy it from Ford $86.00
 

·
TDG Mafia Member#67
Joined
·
5,655 Posts
better than 3K for a trans tho! LOL i have had to replace my trans AND that little sensor! LOL
 

·
SLAPS President
Joined
·
3,027 Posts
dougs03 said:
Teamroper60 Thank you!!!! Replaced the sensor and it is all good,But had to buy it from Ford $86.00
Glad you got her fixed!!:Thumbup: :Thumbup: :Thumbup:
 

·
Registered
Joined
·
624 Posts
good to hear u got it fixed.
 

·
TDG Single Club Member#14
Joined
·
1,086 Posts
Yep that sensor was a pain in the butt got a face full of fluid out of the internal filter.
 

·
Junior Member
Joined
·
14 Posts
Good stuff guys...... I am new here.... but I am having the same exact issue, does any one have a picture or a link to the location of this sensor, and how to replace it.

Thanks a lot!
 

·
off to another home
Joined
·
15,472 Posts
mine was doing that, flashing the tow/haul light but it wasnt going into limp mode and my Isspro would only be at 130 when it would jump up. my trans was on its way out anyways. should have went in sooner. 3200 later it was fixed. HA! didnt even last a year. oh well, its only money right? :shrug:

Garrett
 

·
TDG Single Club Member#14
Joined
·
1,086 Posts
you have to drop the pan and it is in between the shift solonoids on the right side. You pretty much have to hold the sensor in yer hand and match it up with the one inside.
 

·
Registered
Joined
·
1 Posts
Fixed!!

This site saved me LOTS of money i have a 2003 f250 diesel the trans gauge was pegged and the tow haul light was flashing after i took it to a garage and had it tested, they told me i had to have a new transmission was going to be $2,800
so at night i went on here and read what people had to say i took a gamble and went and bought a trans temp censer cost 66 bucks was easy to install and now it works great!! that is all it was, i dam near spent a lot of money for nothing,, so thank you all this place is great!!!...Ed
 
1 - 19 of 19 Posts
Top