The Diesel Garage banner

Status
Not open for further replies.
1 - 12 of 12 Posts

·
T.D.G. Mafia Member #88
Joined
·
578 Posts
Discussion Starter #1
First of all this is for HorseHaulin's new truck, 01 2500 4x4 D-Max( he's on the road and called me).What's the easiest access to the the trans cooler line on the passenger side of the cooler? He said looks lilke the grill needs to be removed but not sure?? Looking for opinions. The line is leaking at the fitting.

Wade
 

·
Senior Member
Joined
·
3,939 Posts
Geezus...who owned and serviced that truck before he bought it?

Only real way to get at the cooler is from the front.
 

·
Senior Member
Joined
·
3,939 Posts
hmm....01 GMC?

You have to remove the upper black rad cover first. I think that cover has 8-10 push-loc fasteners. Use a screwdriver to lift the center up, then pull the fastener out. Dont worry if they separate. Just put the center back in so you can reuse it.

I havent worked on an 02 GMC yet, but I did have an 02 Chevy. There may be a 10mm bolt holding the center of the grill. Remove it. There may also be 4 plastic twist fasteners on the corners of the center grill section. They look like big plastic Phillips-head screws. My 02 Chevy had those. If not, then they're just those metal hook-type push fasteners (like what holds the dash bezel on). There are also 2 of those metal hooks on the very ends of the center bar between the headlights and turn signals. Be careful pulling on those...you can create a lot of stress on the grill bar...dont want him to break it. You also have to watch it when you remove the grill so you can clear the turn signal lights, dont want you to scratch the lens' on either side. Also, there is a small clip that connects this center bar to the front wheel well liner on both sides.


It takes me longer to type that than it actually does to remove the grill.
 

·
TDG Mafia # 81
Joined
·
1,903 Posts
Well thanks again to Tom, I pulled the grille and found the tranny cooler leaking between the first and second row on the tank from the bottom of the cooler fittings. This is really getting frustrating, I havent been able to really drive the truck since I bought it. No fault of Gm or anything like that, this time it looks like someone stabbed it with a screwdriver. No I am furious to say the least. The dealer will be talking to a lawyer on Monday as I contacted one earlier on Friday.

Thanks again Tom, without your help I would have just ripped it off with the winch of the tow truck.

Tony
 

·
Senior Member
Joined
·
3,939 Posts
Stabbed it with a screwdriver?!?!?!? WTF?!?!?!

I'm sorry to hear about your luck with this truck, Tony.

I posted in your S/V thread....call Merchant. He should have one, or know where to find one.
 

·
TDG Mafia # 81
Joined
·
1,903 Posts
They also wired my EGT back up wrong so I have to fix that also, but I think after all this I should have a nice and reliable truck. Just have to get over the growing pains, thats all. I already gave Eric a call and left a message, hopefully he calls early in the AM Monday.

Tony
 

·
Registered
Joined
·
557 Posts
I dont have any coolers anymore, wont be of much help for this one.

Sounds like that truck is just giving fits HH. Not an enjoyable experience sounds like
 

·
TDG Mafia # 81
Joined
·
1,903 Posts
EGT guages work much better when the person attatches the wires after cutting them. I will have that fixed shortly now that I have found that problem. They even forgot to install my air filter restriction guage! I am having them send that to me before I run the truck again. If you cant trust a dealer to fix it right, what does that say about the normal persons car on the road.

Killerbee, you have a PM!

As for the cooler, its inevitable for those to go bad, might as well get a better one since I am this far into it now.

Eric, thanks for the post, you can scratch the call to me here in Fort Wayne.

Tony
 

·
TDG Mafia # 81
Joined
·
1,903 Posts
First, thanks a bunch to a great supporting vendor on this site, Killerbee. He sent a air filter restriction guage to me and that is outstanding! Thanks, you dont know how much that means to me.

Second, let me add to my list of BS thats been happening to this truck since I got it back from the dealer. Tonight after dropping off my son to his mom, I got on it just a little (1/2 throttle) and I hear the boost pop off after letting up and realized I had no more turbo! Pull over to start diagnosis and find the tech forgot to install the C-clip that holds the wastegate actuator to the WG lever. Drove home watching the EGT's with zero boost knowing I would have to be careful. So lets sum this up.

Dealer forgets/screws up,
1, EGT gauge wiring
2, Air Filter restriction guage
3, Transmission oil cooler was punctured
4, WG C-clip not installed
5, Block heater cord not hooked up
6, Dare I ask?

I hope I am reaching the end list of the things that the dealer neglected to do properly.

*** NOTE, this is dealer problems, not Duramax problems. Thus far when the truck runs, it runs outstandingly. But due to what I think is inexperience, I have been forced to fix small things the right way myself.***

Again, thanks goes out to Killerbee for his outstanding support of this site and its members!

Tony
 
1 - 12 of 12 Posts
Status
Not open for further replies.
Top