The Diesel Garage banner

1 - 4 of 4 Posts

·
Senior Member
Joined
·
166 Posts
Discussion Starter #1
posting for a buddy.

I got a 05' 4500 Chevy truck, Duramax with Allison tranny. It's a 4 door long service bed, that i pull a hudson 18' trailer, always
loaded with a T300 Bobcat & 3000 pound spade on it. It's all around 20,000 pounds.
The truck has been showing it's *** lately, it will run throw all the gears fine, but when it goes up a hill or need to shift down(in a pull), it won't do it. It just runs the RPM's up but the tranny won't change down to a proper gear. I have to stop the truck for a few seconds, and/or put in park to start again. It has happen before, but seem's to be worse in the winter time(when cold). Seems like a computer or tranny problem.
It's been to a truck center, but they say if the light ain't on, it ain't broke.
 

·
Registered
Joined
·
22 Posts
Change the Allison's spin on filter. It will not shift correctly if the filter is plugged. Kind of like the way these things run crappy if your fuel filter gets dirty. Also smell the trans fluid and look at the color. Have they checked for codes?? It takes just a minute to do and I can't believe it has not set any codes. Keep us posted.
 

·
'Ol Builder guy
Joined
·
7,051 Posts
It's been to a truck center, but they say if the light ain't on, it ain't broke.
Isn't that typical of today's customer service? Now the mechanics are relying on dummy lights for detecting a problem.....


I agree. Change the spin on.....might as well switch to Transynd while you're doing the filter if you can throw $150 bucks at it. Especially if you're near time for a ATF change anyway.
 
1 - 4 of 4 Posts
Top