The Diesel Garage banner

1 - 4 of 4 Posts

·
Member
Joined
·
79 Posts
Discussion Starter #1
My brother just installed a juice with attitude. WEll in the stock mode the trucks feels solid, even towing. Even if you turn the juice on the tow setting or even the lowest power setting and you even just barely think about pushing the pedle a little while the truck is in overdrive and tc locked it starts to shutter. Now i understand the whole more power and can make a bad trans worse, but he is barely on the throttle so he isn't using the full power the truck has. I have read where bad grounds or corroded batteries and possibly a failing alternator can affect shifts in the tranny? Can anyone give me any info on this. Thanks.

Tim
 

·
Registered
Joined
·
2,189 Posts
bad grounds can cause trany problems in these but unlikely that's your problem. It is probably just because the tranny is weak and the engine has alot more power.

You are making more power at where your throttle was than stock. But your holding pressure is still the same. Just that little increase in power is enough to make the TCC slip. If you want to trouble shoot yourself just take the Edge off and see if it still does it. Any little tweak we do to these engines with the stock transmissions seems to end up bringing up problems.

On top of that if the TCC is all stock they don't seem to like some of the newer ATFs on the market. Even some aftermarket (stock design) TC's don't like ATF+4. Ran into that where we were getting TCC shutter in stockers by running ATF+4. Then simply switching to ATF+3 fixed it. Now the new fluids now may have additives that probably demish that. But back a number of years ago it was a problem.
 

·
Senior Member
Joined
·
232 Posts
your tranny is having trouble with all the power. mine did the same thing for the first month with the juice but aftee that it went away then after that a needed a new trans in 6 months :( u need more pressure (VB) and a better TC
 

·
Member
Joined
·
57 Posts
I have been having the same type of problem with mine,but its a 5 speed with a brand new clutch. Not a southbend not enough cash right now but a luk performance gold. If your driving down the highway and you just give a little more throttle just to maintain speed not even pulling anything it will shutter sort-of. Mine feels like you tap the brakes real fast-repeativly. I have heard that possably the ring for the anti-lock brakes can cause this. Mine seems to do it worse using cruise. Which I think the ring controls that to. Now I think I have a caliper sticking so I dont know if it has something to do with it or not.:shrug: Hope you find the problem I know mine is driving me nuts.
 
1 - 4 of 4 Posts
Top