The Diesel Garage banner

1 - 8 of 8 Posts

·
Junior Member
Joined
·
12 Posts
Discussion Starter #1
coming home yesterday came around acorner trans made loud bang. i have felt this before. after 1 mile down the road trans gauge droped to 0 engine lite came on 1/4 mile later wrench lite came on trans went to i think third.istoped checked code it said tran temp sensor.kept checking guage after 15 minutes temp went to normal [with the truck off] drove it 1/2 mile temp droped again towed it home put it to stock.there was no code.so i drove it to throw acode after 50 miles i stil cant get it to do it again. worked fine no problems.now what i gues ill drive it stock for a while.any in put .[210 tune]
 

·
Senior Member
Joined
·
2,183 Posts
I've never heard of that one before. I know most of the trucks will slam into gear occasionally but never heard of the temp sensor thing. I'm sure someone more knowledgeable will chime in soon.
 

·
Junior Member
Joined
·
145 Posts
mine and many others do this while rounding a corner @ about 20mph...when you coast & ease back on the gas it bangs like the trans was getting confused then itll rev higher until my tq converter or hit OD or w/e that is kicks in @ 50-55mph..i got the 250hp spartan...sum say its cuz your low on fluid but theres been ppl who added more w/e results..no ones ever figured it out 2 my knowledge..just none of us had ever got the code or temps like u did when it happens
 

·
Junior Member
Joined
·
86 Posts
so to chime in i have a 2010 250 and it banged so hard twice in a row that it went into limp mode and wouldnt shift out of second gear had the wrench lite come on and brought to my shop plugged IDS in and got two codes retaining to the frictions plates in the trans and the selenoid so droped the pan put a new selenoid in and added and extra quart it went good for about to days then went back to banging hard but no codes this time so a lil confused dont know wat to do from this point
 

·
Junior Member
Joined
·
12 Posts
Discussion Starter #5
dealer looked at truck today.said temp sensor was bad and had to drop the valvebody.they also told me there was a harness upgrade for the tranny.70000 miles so i have to pay the bill about 800 bucks for about 4hours of work
 

·
Junior Member
Joined
·
86 Posts
yeah the trans 5 year 60 and motor 5 year 100,000 wat type of upgraded wiring and if u could test it out and let me know how it goes if you get the banging to come back
 

·
Junior Member
Joined
·
12 Posts
Discussion Starter #8
got the truck back tonight. they told me the new wiring harnes had to be done because the newer sensors have a diferent conector on them.already took dpf off getting faster at it.i found that if you knock the studs out of the dpf you dont have to loosen any hangers.it will drop strait down and pull it forward to slide it out of the tail pipe.dont know if anybody has doe this before.
 
1 - 8 of 8 Posts
Top