The Diesel Garage banner
1 - 4 of 4 Posts

·
stroke this
Joined
·
35 Posts
Discussion Starter · #1 ·
I'm having a problem starting my truck kinda weird actually. It'll start fine cold like in the morning or after it's been sittin for about 2-3 hrs but after i run it and its warmed up then shut off the truck it has a hard time re-starting or it won't start at all just cranks. changed the fuel filter thinking it might not be getting fuel but that didn't help don't know if it could be cam sensor or fuel pump anyone else have this problem or anyone be able to help that would be great.
 

·
TDG MAFIA #101
Joined
·
390 Posts
This sounds like when the fuel pump went out of mine. Maybe someone will chime in and tell you how to check for sure.
 

·
stroke this
Joined
·
35 Posts
Discussion Starter · #3 ·
just got done looking at http://www.powerstroke.org/forum/94-98-7-3l-problem-forum/14156-95-7-3l-wont-start-when-warm.html and someone on there had the same prob and they were told it was the IPR o-rings so im gonna check that out on mine prob tomorrow and that fixed there prob so hopefully it'll fix mine to and i checked my fuel pressure on the relive valve today and had plenty of pressure changed the cam sensor and still did it stated think starter solenoid but don't know hopefully the IRP o-rings is what it is we'll find out tomorrow and thanks for your input.
 

·
TDG MAFIA #101
Joined
·
390 Posts
Good luck hope it gets fixed, not much worse than not haveing a running truck. :damnit
 
1 - 4 of 4 Posts
Top