The Diesel Garage banner

1 - 10 of 10 Posts

·
Registered
Joined
·
48 Posts
Discussion Starter #1
Over the last few weeks I've noticed my truck acting different: exhaust volume is down, fuel mileage is down, power is down. The truck still runs fine otherwise, just finished a 2500 mi trip without problems...other than fuel prices. I was wondering if anyone else has ever seen these symptoms or maybe have an idea of what it might be. Thanks for the help.

-Will
 

·
Registered
Joined
·
16 Posts
uve gottin use to it lol i use to have edge ez try attuide youll have power then then try injetor tips perfet allwas have power lol :93C_peelo :40oz :40oz :40oz :40oz :grd :grd :dodge :dodge :dodge :dodge :dodge :smoke :smoke :smoke :smoke :smoke :HappyMugs :HappyMugs :agreed: :agreed:
 

·
Registered
Joined
·
48 Posts
Discussion Starter #3
I would agree with you but the mileage is considerably lower and other people have commented on the truck being quieter.
 

·
Senior Member
Joined
·
3,514 Posts
I'd check your fuel filter. That can make a huge difference. Also check for codes, it could be that you're starting to lose timing. Except you have a new vp in that thing don't you?
Sean
 

·
Registered
Joined
·
48 Posts
Discussion Starter #5
I haven't replaced the VP yet I'm still trying to figure out if that's the problem before sinking the money for a new one.
 

·
Member
Joined
·
71 Posts
what about ULSD?
 

·
Registered
Joined
·
69 Posts
my truck had the same problem and it ended up being and injection pump, if i wouldent have been so damn lazy and changed my fuel filter when i should have that would have never happened. Check the fuel filter first and check fuel pressure also.
 

·
2nd Gen Guru
Joined
·
2,641 Posts
hemichallenger said:
Over the last few weeks I've noticed my truck acting different: exhaust volume is down, fuel mileage is down, power is down. The truck still runs fine otherwise, just finished a 2500 mi trip without problems...other than fuel prices. I was wondering if anyone else has ever seen these symptoms or maybe have an idea of what it might be. Thanks for the help.

-Will
Do you have fuel pressure gauge? If so what is your pressure at WOT?

If you don't have a fuel pressure gauge I highly suggest you do a pump diagnostic.
http://mopar.mopar1973man.com/2002 Dodge/Tips & Tricks/lift pump/lift pump.htm

Have you changed you fuel filter lately?
http://mopar.mopar1973man.com/2002 Dodge/Tips & Tricks/maintenance/Maintenance.htm

Have you checked for codes?
http://mopar.mopar1973man.com/2002 Dodge/Tips & Tricks/error codes/error_codes.htm

Are you using too much injection cleaners and/or cetane boosters? High cetane fuel tends to be much lower in BTU's and will reduce MPG's greatly.
 

·
Registered
Joined
·
48 Posts
Discussion Starter #9
Fuel Filter has been changed, haven't run through the codes, and don't have a guage hooked up, i'll go through the codes this weekend and see what they say.
 

·
2nd Gen Guru
Joined
·
2,641 Posts
hemichallenger said:
Fuel Filter has been changed, haven't run through the codes, and don't have a guage hooked up, i'll go through the codes this weekend and see what they say.
Don't forget to check the pump flow... If the LP (Lift Pump) is dead the VP44 (Injection pump) is taking a beating. A lot of performance and fuel mileage issues revolve around the fuel system...:poke:
 
1 - 10 of 10 Posts
Top