The Diesel Garage banner

1 - 3 of 3 Posts

·
Member
Joined
·
278 Posts
Discussion Starter #1
Tore another boot towing this weekend. I have 08 with spartan tune. I run the 210 tune. I have had terrible time with boots. Stock ones did alright but blew several off and tore two of them. I tried the dieselsite boots those blew off and tore. Got a set of Riffraff ones those have held the best but tore one this weekend. I have double clamped and tried using tie wire to help hold the pipe in place. I just don't understand why I am having so many problems. I honestly don't even run the truck that hard try not to ever boost over 30 PSI when I am towing but many guys claim they are seeing over 50 PSI. I do tow a 40' heavy 5th wheel tow hauler and my truck is lifted with 37's but plenty of guys run the same set up. I am at a lost. Love the truck but this is about my 10th boot and it is getting old. Of course it always happens at the worst time and leaves you stranded until you get a new boot on there.

Any ideas?
 

·
Junior Member
Joined
·
17 Posts
Broth I'm not sure what the problem with the intercooler boots may be I run the 250 tune with 35's and have never had a problem I have the bd intercooler pipe on my truck as well and upgraded the clamps when I put the intercooler pipe on I'm sure your already using the the good stainless steel clamps but check your torque on them when you get a chance, I would also check the intercooler for loose mounts, just my two cents, do the boots always blow off when ur under heavy load or will it happen anytime no matter what boost your at?
 

·
Member
Joined
·
278 Posts
Discussion Starter #3
Only under a heavy load and has happen with as little as 30 PSI boost while towing heavy only. I check the clamps each time before I tow to make sure they are tight because I have had such a problem. I will check the intercooler as well.
 
1 - 3 of 3 Posts
Top