The Diesel Garage banner

1 - 16 of 16 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Howdy y'all-
Just had the Edge Platinum installed yesterday on my new '06 250 4x4 TorqueShift. When I hit it hard on take-off, it emits an initial vibration (after the turbo lag) that seems to be coming from the tranny, which subsides when it reaches the shift point. This happens in first gear only and is more pronounced with higher power level settings. I don't recall this vibration prior to yesterday's install. Is it the tires trying to break loose, or something bad happening in the tranny?

Also, this "lag" is driving me crazy! Will the Airaid Intake fix it?

Thanks in advance for any advice you can offer.
 

·
Registered
Joined
·
311 Posts
Ride-Orange,

Sounds like your converter is slipping to me. Get the AFE Mega Stage II systems as far as air intakes, biggest filter most CFM of flow etc. It'll help on the lag issue. Call us if you have any questions on it.

Mark @ DPPI
 

·
Registered
Joined
·
162 Posts
Squatch said:
I would say it is driveline shudder from the axle rap on take off.
"DITTO":Thumbup: Have the same issue with mine....no Edge but do have a 3" lift. The problem was worse with just the leveling kit. I read a TSB on this somewhere as well. Also read on the Ford Tech Forum that the following diagnostics and fix are available. If the vibes are less pronounced when the truck is loaded the wedge blocks on the rear diff need to be flipped so the skinny end is to the front, reducing the drive line angle. If worse when loaded then you may need a steeper wedge or shims or the wedge block was installed incorrectly. Alternately, the TSB indicates that you can shim the centre carrier bracket using 1/4" shims to a maximum of 3/4"

I have attached the TSB for your information.:Thumbup:
 

Attachments

·
Registered
Joined
·
324 Posts
I had that issue after a few of my mods. Fixed it with traction bars from Farmboy Fabrications!! LOVE'EM. Talk about a hard launch too!! WOW!!
 

·
Registered
Joined
·
2,997 Posts
Im with squatch, MY 06` shudders under a hard load. It did it stock also with a heavy trailer. Its the nature of a u-joint under a heavy load. They speed up and slow down in every rotation.
 

·
Registered
Joined
·
162 Posts
6L PWR said:
I had that issue after a few of my mods. Fixed it with traction bars from Farmboy Fabrications!! LOVE'EM. Talk about a hard launch too!! WOW!!
Any Pics of the traction bars mounted on the truck?????:squish
 

·
Registered
Joined
·
324 Posts
wsa308 said:
Any Pics of the traction bars mounted on the truck?????:squish
Not yet, but I'll try to get some this weekend. They're really sweet. I bought them from a guy on here. I'm trying to find the thread where I found him and post a link for everyone. Cost was $475 if I remember right. I had a buddy help me install them. They came with bolts to go to the frame and plates to weld onto the axle, but we just welded both since we had to weld to begin with.
 

·
Registered
Joined
·
79 Posts
I have the same vibration, shutter on my 06, installed traction bars, did not help one bit, seems to ride rougher as well, good luck.
 

·
Registered
Joined
·
324 Posts
wsa308 said:
Any Pics of the traction bars mounted on the truck?????:squish
Alrighty! Found three threads talking about Jesse that made mine. One even includes some pics for ya'll.

WILDCAT said:
CBSuperduty said:
If you ever go to FTW then you may want to check with BigGreen (I think that is his name) he has been making some for some guys and they all seem to be extremely happy.
COTTS4x4 said:
I have a set of bars made by Bigreen. I have no axle wrap what-so-ever. Here is a link to the thread on Ford Truck World. http://fordtruckworld.tenmagazines.c...bars_installed

Jesse is making a set for a friend of mine in the next week or so.
 

·
Registered
Joined
·
324 Posts
FUDGE! The links didn't come through. Guess you can search the threads for them though. That's how I finally found them. Of course, it'd be easier searching for BigGreen than the way I found them! lol
 

·
Registered
Joined
·
4 Posts
Discussion Starter #12
:bow: Thanks for the replies fellas. Glad to hear that my tranny isn't coming apart already! It dawned on me that I had airbags installed the same day. I did this for trailering purposes, but the kid that installed them for me thought I was looking for a lift :damnit He had 70 psi in them which equated to about 3" (and a STIFF ride). That, coupled with the short wheel base, changed the drive line angle dramatically. After airing down to 20 psi the shudder is greatly reduced :pointlaugh I race dirt bikes, but not the truck. I think I can control the shudder with my right foot from now on:93C_peelo , but may got to the traction bars later.

AFE Mega System 2 is delivering today and installing tomorrow:woot:
:usflag :thanks:
 

·
Registered
Joined
·
1,592 Posts
Go to the ford performance forum there is a long post about them. you can look on the web site www.fluidampr.com too. they have dyno graphs on it. im not saying it will cure all your problems but will help. when you start adding power mods to your truck you need one to help control all the nasty harmonics.
 
1 - 16 of 16 Posts
Top