The Diesel Garage banner

1 - 5 of 5 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
i seen the post someone put about turning the key on and off 3 times.i got 2 things 1st p pcu 2nd p ecu.can any one help i also have the super chips d-box on the truck could this be the reason thanks for any info
 

·
TDG Mafia Member #21
Joined
·
1,345 Posts
It would help if you filled out your signature box so we know what you are driving. Were there any numbers present after the pcu and ecu?
 

·
TDG Mafia Member #21
Joined
·
1,345 Posts
It sounds like it could be the box but that would only be a guess. Without a specific code and both the ecu and pcu showing I would think it was maybe a general type fault caused by the programmer. There are also codes that show up as a general fault code that don't give a specific cause. I believe those have to be read by the dealer because they are Chrysler specific. Try pulling the programmer and see if that helps.:shrug: You may need to have the codes cleared after pulling it. If that clears it up, put the programmer back on and see if it comes back. If it does you have your answer. Maybe Bouncer or one of the other guys will chime in here and lend a little more wisdom to the problem.
 

·
TDG Mafia 36
Joined
·
591 Posts
I had a similar problem with my truck, I have an Edge EZ and started getting injector pump codes:damnit Took the chip off cleared the codes and they didn't come back, but as soon as I put the chip back on, same code came back. Mine ended up being a bad chip, just something else to look into if you don't come up with anything else.
 
1 - 5 of 5 Posts
Top