The Diesel Garage banner

1 - 5 of 5 Posts

·
Member
Joined
·
142 Posts
Discussion Starter #1
My oil temp readings are strangly different, don't know if it is the truck or monitors.

Morning start up 75 ambient:
Dash Daq Livewire
ECT 110 125
EOT 109 60
EFTI 100 NA
TFT 105 107

After running about 30 min 90 ambient:
Dash Daq Livewire
ECT 192 194
EOT 192 90
EFTI 126 NA
TFT 160 160

I'm wondering how acurate the monitors are as my coolant, oil, and trans temps hit in the 225's while towing but the fan never kicks, so maybe its really not that hot
 

·
Member
Joined
·
278 Posts
The EOT is the only thing that seems way off. Not sure what to say other than I had a huge problem with EOT. I would run about 220-230 empty on flat land once I hooked a trailer to it I saw 270 + in regards to EOT but everything else was fine. Cab off repair to fix the oil cooler in which they replaced but they actually thought that it has to do with the thermostat in the oil cooler not the oil cooler itself?? My dealer claimed there is some type of problem with them and several have had this problem. I got a whole new set up and has been fine ever since. About 190-200 flat land now!!!
 

·
Junior Member
Joined
·
122 Posts
I don't have a DD but my Livewire shows EOT temps around the same as what you are showing. It's always seemed extremely low to me. The rest of the numbers are about the same.
 

·
Member
Joined
·
142 Posts
Discussion Starter #5
EOT on Livewire is Celsius. 90C = 194F.

Thats always been annoying to me... my Livewire does EGT's and EOT in celsius, and engine coolant, trans, in fahrenheit.
Thanks - I read that along time back and forgot about it
 
1 - 5 of 5 Posts
Top